As per my issue on GitHub (https://github.com/highfidelity/hifi/issues/14171), Ubuntu 16.04 has a problem: both cmake 3.9 and python 3.6 are not natively available on apt-get. While I can resolve the cmake instructions (which works also for Ubuntu 18.04), the python issue is something I'm unsure of. Please address these concerns as the issue keeps getting pushed back and is nearly 4 months old.